// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<audio\s+src="([^"]*)"[^>]*>"#).unwrap();
let string = "<p><audio src=\"test.mp3\" controls=\"controls\"></audio></p>
<p><audio src=\"test2.mp3\" controls=\"controls\"></audio></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}