import re
regex = re.compile(r"<audio\s+src=\"([^\"]*)\"[^>]*>", flags=re.IGNORECASE)
test_str = ("<p><audio src=\"test.mp3\" controls=\"controls\"></audio></p>\n"
"<p><audio src=\"test2.mp3\" controls=\"controls\"></audio></p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")