using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s;]{3,})";
string input = @"group1 ; group2 ;
group1 ; group2 ; group3 ; group5 ;
group1 ; group2 ; group3 ; group4 ; group5 ; group6 ; ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}