const regex = /([^\s;]{3,})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\s;]{3,})', 'gm')
const str = `group1 ; group2 ;
group1 ; group2 ; group3 ; group5 ;
group1 ; group2 ; group3 ; group4 ; group5 ; group6 ; `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}