package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\s;]{3,})`)
var str = `group1 ; group2 ;
group1 ; group2 ; group3 ; group5 ;
group1 ; group2 ; group3 ; group4 ; group5 ; group6 ; `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}