$re = '/([^\s;]{3,})/m';
$str = 'group1 ; group2 ;
group1 ; group2 ; group3 ; group5 ;
group1 ; group2 ; group3 ; group4 ; group5 ; group6 ; ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);