re = /([^\s;]{3,})/m
str = 'group1 ; group2 ;
group1 ; group2 ; group3 ; group5 ;
group1 ; group2 ; group3 ; group4 ; group5 ; group6 ; '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end