import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[1-578]\\d\\d|(?:0\\d[1-9]|0[1-9]\\d)|(?:6\\d[0-57-9]|6[0-57-9]\\d)";
final String string = "I am supposed to exclude the numbers 000, 666, and all numbers between 900-999.\n\n"
+ "001\n"
+ "000\n"
+ "002\n"
+ "100\n"
+ "600\n"
+ "660\n"
+ "666\n"
+ "606\n"
+ "900\n"
+ "899\n"
+ "999\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}