const regex = /[1-578]\d\d|(?:0\d[1-9]|0[1-9]\d)|(?:6\d[0-57-9]|6[0-57-9]\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[1-578]\\d\\d|(?:0\\d[1-9]|0[1-9]\\d)|(?:6\\d[0-57-9]|6[0-57-9]\\d)', 'g')
const str = `I am supposed to exclude the numbers 000, 666, and all numbers between 900-999.
001
000
002
100
600
660
666
606
900
899
999
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}