import re
regex = re.compile(r"[1-578]\d\d|(?:0\d[1-9]|0[1-9]\d)|(?:6\d[0-57-9]|6[0-57-9]\d)")
test_str = ("I am supposed to exclude the numbers 000, 666, and all numbers between 900-999.\n\n"
"001\n"
"000\n"
"002\n"
"100\n"
"600\n"
"660\n"
"666\n"
"606\n"
"900\n"
"899\n"
"999\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")