re = /[1-578]\d\d|(?:0\d[1-9]|0[1-9]\d)|(?:6\d[0-57-9]|6[0-57-9]\d)/
str = 'I am supposed to exclude the numbers 000, 666, and all numbers between 900-999.
001
000
002
100
600
660
666
606
900
899
999
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end