#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)["“”]\d{1,2}\/[A-Za-z]{3}\/\d{4}["“”]"
Local $sString = "{{field(“dd/MMM/yyyy")}} -> “dd/MMM/yyyy"" & @CRLF & _
"{{field("dd/MMM/yyyy“)}} -> "dd/MMM/yyyy“" & @CRLF & _
"{{field("dd/MMM/yyyy")}} -> "dd/MMM/yyyy"" & @CRLF & _
"{{field(“dd/MMM/yyyy“)}} -> “dd/MMM/yyyy“" & @CRLF & _
"{{field(“dd/MMM/yyyy“)}} -> “dd/MMM/yyyy“" & @CRLF & _
"{{field(”dd/MMM/yyyy")}} -> ”dd/MMM/yyyy"" & @CRLF & _
"{{field("dd/MMM/yyyy”)}} -> "dd/MMM/yyyy" & @CRLF & _
"{{field(”dd/MMM/yyyy”)}} -> ”dd/MMM/yyyy”" & @CRLF & _
""08/Feb/2021""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")