package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)["“”]\d{1,2}\/[A-Za-z]{3}\/\d{4}["“”]`)
var str = `{{field(“dd/MMM/yyyy")}} -> “dd/MMM/yyyy"
{{field("dd/MMM/yyyy“)}} -> "dd/MMM/yyyy“
{{field("dd/MMM/yyyy")}} -> "dd/MMM/yyyy"
{{field(“dd/MMM/yyyy“)}} -> “dd/MMM/yyyy“
{{field(“dd/MMM/yyyy“)}} -> “dd/MMM/yyyy“
{{field(”dd/MMM/yyyy")}} -> ”dd/MMM/yyyy"
{{field("dd/MMM/yyyy”)}} -> "dd/MMM/yyyy
{{field(”dd/MMM/yyyy”)}} -> ”dd/MMM/yyyy”
"08/Feb/2021"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}