import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\"“”]\\d{1,2}\\/[A-Za-z]{3}\\/\\d{4}[\"“”]";
final String string = "{{field(“dd/MMM/yyyy\")}} -> “dd/MMM/yyyy\"\n"
+ "{{field(\"dd/MMM/yyyy“)}} -> \"dd/MMM/yyyy“\n"
+ "{{field(\"dd/MMM/yyyy\")}} -> \"dd/MMM/yyyy\"\n"
+ "{{field(“dd/MMM/yyyy“)}} -> “dd/MMM/yyyy“\n"
+ "{{field(“dd/MMM/yyyy“)}} -> “dd/MMM/yyyy“\n"
+ "{{field(”dd/MMM/yyyy\")}} -> ”dd/MMM/yyyy\"\n"
+ "{{field(\"dd/MMM/yyyy”)}} -> \"dd/MMM/yyyy\n"
+ "{{field(”dd/MMM/yyyy”)}} -> ”dd/MMM/yyyy”\n"
+ "\"08/Feb/2021\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}