re = /["“”]\d{1,2}\/[A-Za-z]{3}\/\d{4}["“”]/m
str = '{{field(“dd/MMM/yyyy")}} -> “dd/MMM/yyyy"
{{field("dd/MMM/yyyy“)}} -> "dd/MMM/yyyy“
{{field("dd/MMM/yyyy")}} -> "dd/MMM/yyyy"
{{field(“dd/MMM/yyyy“)}} -> “dd/MMM/yyyy“
{{field(“dd/MMM/yyyy“)}} -> “dd/MMM/yyyy“
{{field(”dd/MMM/yyyy")}} -> ”dd/MMM/yyyy"
{{field("dd/MMM/yyyy”)}} -> "dd/MMM/yyyy
{{field(”dd/MMM/yyyy”)}} -> ”dd/MMM/yyyy”
"08/Feb/2021"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end