using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[""“”]\d{1,2}\/[A-Za-z]{3}\/\d{4}[""“”]";
string input = @"{{field(“dd/MMM/yyyy"")}} -> “dd/MMM/yyyy""
{{field(""dd/MMM/yyyy“)}} -> ""dd/MMM/yyyy“
{{field(""dd/MMM/yyyy"")}} -> ""dd/MMM/yyyy""
{{field(“dd/MMM/yyyy“)}} -> “dd/MMM/yyyy“
{{field(“dd/MMM/yyyy“)}} -> “dd/MMM/yyyy“
{{field(”dd/MMM/yyyy"")}} -> ”dd/MMM/yyyy""
{{field(""dd/MMM/yyyy”)}} -> ""dd/MMM/yyyy
{{field(”dd/MMM/yyyy”)}} -> ”dd/MMM/yyyy”
""08/Feb/2021""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}