import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\{|function )(\\{\\{(?!#|\\{|\\d|[A-Z]+|[<>])|invoke:|[Cc]ategory:|[Mm]odule:|[Pp]ortal:)(?!Wt/ckb|gsub\\()";
final String string = "{{<includeonly>safesubst:</includeonly>#invoke:ping user|ping}}<noinclude>{{documentation}}</noinclude>";
final String subst = "$1Wt/ckb/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}