$re = '/(?<!\{|function )(\{\{(?!#|\{|\d|[A-Z]+|[<>])|invoke:|[Cc]ategory:|[Mm]odule:|[Pp]ortal:)(?!Wt/ckb|gsub\()/';
$str = '{{<includeonly>safesubst:</includeonly>#invoke:ping user|ping}}<noinclude>{{documentation}}</noinclude>';
$subst = "$1Wt/ckb/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;