use strict;
my $str = '{{<includeonly>safesubst:</includeonly>#invoke:ping user|ping}}<noinclude>{{documentation}}</noinclude>';
my $regex = qr/(?<!\{|function )(\{\{(?!#|\{|\d|[A-Z]+|[<>])|invoke:|[Cc]ategory:|[Mm]odule:|[Pp]ortal:)(?!Wt/ckb|gsub\()/p;
my $subst = '$1Wt/ckb/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";