import re
regex = re.compile(r"(?<!\{|function )(\{\{(?!#|\{|\d|[A-Z]+|[<>])|invoke:|[Cc]ategory:|[Mm]odule:|[Pp]ortal:)(?!Wt/ckb|gsub\()")
test_str = "{{<includeonly>safesubst:</includeonly>#invoke:ping user|ping}}<noinclude>{{documentation}}</noinclude>"
subst = "$1Wt/ckb/"
result = regex.sub(subst, test_str)
if result:
print(result)