#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(\([11]{2,2}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{4,4}|\([0-9]{3,3}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{3,3}|\([0-9]{4,4}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{2,2})[ -\.]{1,1}[0-9]{4,4}$"
Local $sString = "(1212) 2354-1231" & @CRLF & _
"(1212)2354-1231"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")