package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\([11]{2,2}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{4,4}|\([0-9]{3,3}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{3,3}|\([0-9]{4,4}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{2,2})[ -\.]{1,1}[0-9]{4,4}$`)
var str = `(1212) 2354-1231
(1212)2354-1231`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}