import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\([11]{2,2}\\)([ -\\.]{0,1}[1]{1,1}[5]{1,1}[ -\\.]{0,1}){0,1}[ -\\.]{0,1}[0-9]{4,4}|\\([0-9]{3,3}\\)([ -\\.]{0,1}[1]{1,1}[5]{1,1}[ -\\.]{0,1}){0,1}[ -\\.]{0,1}[0-9]{3,3}|\\([0-9]{4,4}\\)([ -\\.]{0,1}[1]{1,1}[5]{1,1}[ -\\.]{0,1}){0,1}[ -\\.]{0,1}[0-9]{2,2})[ -\\.]{1,1}[0-9]{4,4}$";
final String string = "(1212) 2354-1231\n"
+ "(1212)2354-1231";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}