re = /^(\([11]{2,2}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{4,4}|\([0-9]{3,3}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{3,3}|\([0-9]{4,4}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{2,2})[ -\.]{1,1}[0-9]{4,4}$/
str = '(1212) 2354-1231
(1212)2354-1231'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end