use strict;
my $str = '(1212) 2354-1231
(1212)2354-1231';
my $regex = qr/^(\([11]{2,2}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{4,4}|\([0-9]{3,3}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{3,3}|\([0-9]{4,4}\)([ -\.]{0,1}[1]{1,1}[5]{1,1}[ -\.]{0,1}){0,1}[ -\.]{0,1}[0-9]{2,2})[ -\.]{1,1}[0-9]{4,4}$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}