using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![\.-])(?:[a-zA-Z0-9-.](?!\.$)){1,21}$";
string input = @"gareth
gareth.dawson
gd250
g-d-dason
012345678901234567890
reallylongnamethatismorethan20
ending.dot.
Raphaƫl
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}