import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![\\.-])(?:[a-zA-Z0-9-.](?!\\.$)){1,21}$";
final String string = "gareth\n"
+ "gareth.dawson\n"
+ "gd250\n"
+ "g-d-dason\n"
+ "012345678901234567890\n\n\n"
+ "reallylongnamethatismorethan20\n"
+ "ending.dot.\n"
+ "Raphaƫl\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}