use strict;
my $str = 'gareth
gareth.dawson
gd250
g-d-dason
012345678901234567890
reallylongnamethatismorethan20
ending.dot.
Raphaƫl
';
my $regex = qr/^(?![\.-])(?:[a-zA-Z0-9-.](?!\.$)){1,21}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}