re = /^(?![\.-])(?:[a-zA-Z0-9-.](?!\.$)){1,21}$/m
str = 'gareth
gareth.dawson
gd250
g-d-dason
012345678901234567890
reallylongnamethatismorethan20
ending.dot.
Raphaƫl
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end