$re = '/^(?![\.-])(?:[a-zA-Z0-9-.](?!\.$)){1,21}$/m';
$str = 'gareth
gareth.dawson
gd250
g-d-dason
012345678901234567890
reallylongnamethatismorethan20
ending.dot.
Raphaƫl
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);