#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sxi) (?(DEFINE)" & @CRLF & _
" (?<warranty_word> ([a-zäöüßÖÜÄ0-9-]+)?garantie[*]?)" & @CRLF & _
")" & @CRLF & _
"(?&warranty_word)"
Local $sString = "3 Jahre Vor-Ort-Garantie"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")