import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (?(DEFINE)\n"
+ " (?<warranty_word> ([a-zäöüßÖÜÄ0-9-]+)?garantie[*]?)\n"
+ ")\n"
+ "(?&warranty_word)";
final String string = "3 Jahre Vor-Ort-Garantie";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}