package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si) (?(DEFINE)
(?<warranty_word> ([a-zäöüßÖÜÄ0-9-]+)?garantie[*]?)
)
(?&warranty_word)`)
var str = `3 Jahre Vor-Ort-Garantie`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}