re = / (?(DEFINE)
(?<warranty_word> ([a-zäöüßÖÜÄ0-9-]+)?garantie[*]?)
)
(?&warranty_word)/xi
str = '3 Jahre Vor-Ort-Garantie'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end