using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bPort\s+\S+(?:\s+\S+)?";
string input = @"Strong winds may disrupt operations at the Port of Rotterdam on July 5
Strong winds may disrupt operations at the Port of";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}