package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bPort\s+\S+(?:\s+\S+)?`)
var str = `Strong winds may disrupt operations at the Port of Rotterdam on July 5
Strong winds may disrupt operations at the Port of`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}