$re = '/\bPort\s+\S+(?:\s+\S+)?/m';
$str = 'Strong winds may disrupt operations at the Port of Rotterdam on July 5
Strong winds may disrupt operations at the Port of';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);