# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[url(?|]((https?:\/\/[^[]+))|(?:=['"]?(https?:\/\/[^]]+?)['"]?)](.+?))\[\/url]/<a href=\"$1\">$2<\/a>/ig;t' <<< "[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url=\"nourl\"]nourl[/url]
[URL=\"https://any.com/any?any=333\"]text text[/URL]
[url=\"http://www.emptyTEXT.com\"][/url]
[url]http://www.any.com/any?any=44#sss[/url]
[url='http://www.singlequoting.com']Single Quoting[/url]
[url=http://www.noquoting.com]No Quoting[/url]"