use strict;
my $str = '[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url="nourl"]nourl[/url]
[URL="https://any.com/any?any=333"]text text[/URL]
[url="http://www.emptyTEXT.com"][/url]
[url]http://www.any.com/any?any=44#sss[/url]
[url=\'http://www.singlequoting.com\']Single Quoting[/url]
[url=http://www.noquoting.com]No Quoting[/url]';
my $regex = qr~\[url(?|]((https?://[^[]+))|(?:=['"]?(https?://[^]]+?)['"]?)](.+?))\[/url]~ip;
my $subst = '<a href=\\"$1\\">$2</a>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";