import Foundation
let pattern = #"\[url(?|]((https?://[^[]+))|(?:=['"]?(https?://[^]]+?)['"]?)](.+?))\[/url]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
[URL]www.no.http.example.com[/URL]
[url]https://any.com/any[/url]
[url="nourl"]nourl[/url]
[URL="https://any.com/any?any=333"]text text[/URL]
[url="http://www.emptyTEXT.com"][/url]
[url]http://www.any.com/any?any=44#sss[/url]
[url='http://www.singlequoting.com']Single Quoting[/url]
[url=http://www.noquoting.com]No Quoting[/url]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href=\"$1\">$2</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)