# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[url(?|]((https?://[^[]+))|(?:=['\"]?(https?://[^]]+?)['\"]?)](.+?))\[/url]"
test_str = ("[URL]www.no.http.example.com[/URL]\n"
"[url]https://any.com/any[/url]\n"
"[url=\"nourl\"]nourl[/url]\n"
"[URL=\"https://any.com/any?any=333\"]text text[/URL]\n"
"[url=\"http://www.emptyTEXT.com\"][/url]\n"
"[url]http://www.any.com/any?any=44#sss[/url]\n"
"[url='http://www.singlequoting.com']Single Quoting[/url]\n"
"[url=http://www.noquoting.com]No Quoting[/url]")
subst = "<a href=\\\"$1\\\">$2</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.