import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[url(?|]((https?://[^[]+))|(?:=['\"]?(https?://[^]]+?)['\"]?)](.+?))\\[/url]";
final String string = "[URL]www.no.http.example.com[/URL]\n"
+ "[url]https://any.com/any[/url]\n"
+ "[url=\"nourl\"]nourl[/url]\n"
+ "[URL=\"https://any.com/any?any=333\"]text text[/URL]\n"
+ "[url=\"http://www.emptyTEXT.com\"][/url]\n"
+ "[url]http://www.any.com/any?any=44#sss[/url]\n"
+ "[url='http://www.singlequoting.com']Single Quoting[/url]\n"
+ "[url=http://www.noquoting.com]No Quoting[/url]";
final String subst = "<a href=\\\"$1\\\">$2</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}