using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+([-+.']\w+)*@?(abbott.com$|24sq.com$|nhs.uk$|nhs.net$|'nobles.dhss.gov.im$|gov.gg$|diabetes.org.uk$|thelondonclinic.co.uk$|thewellnessjunction.com$|bramacare.co.uk$|\w+\.hscni.net$|\w+\.ie$)";
string input = @"aa3@sss.ie";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}