re = /^\w+([-+.']\w+)*@?(abbott.com$|24sq.com$|nhs.uk$|nhs.net$|'nobles.dhss.gov.im$|gov.gg$|diabetes.org.uk$|thelondonclinic.co.uk$|thewellnessjunction.com$|bramacare.co.uk$|\w+\.hscni.net$|\w+\.ie$)/m
str = 'aa3@sss.ie'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end