// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\w+([-+.']\w+)*@?(abbott.com$|24sq.com$|nhs.uk$|nhs.net$|'nobles.dhss.gov.im$|gov.gg$|diabetes.org.uk$|thelondonclinic.co.uk$|thewellnessjunction.com$|bramacare.co.uk$|\w+\.hscni.net$|\w+\.ie$)").unwrap();
let string = "aa3@sss.ie";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}