$re = '/^\w+([-+.\']\w+)*@?(abbott.com$|24sq.com$|nhs.uk$|nhs.net$|\'nobles.dhss.gov.im$|gov.gg$|diabetes.org.uk$|thelondonclinic.co.uk$|thewellnessjunction.com$|bramacare.co.uk$|\w+\.hscni.net$|\w+\.ie$)/m';
$str = 'aa3@sss.ie';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);