const regex = /^\w+([-+.']\w+)*@?(abbott.com$|24sq.com$|nhs.uk$|nhs.net$|'nobles.dhss.gov.im$|gov.gg$|diabetes.org.uk$|thelondonclinic.co.uk$|thewellnessjunction.com$|bramacare.co.uk$|\w+\.hscni.net$|\w+\.ie$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+([-+.\']\\w+)*@?(abbott.com$|24sq.com$|nhs.uk$|nhs.net$|\'nobles.dhss.gov.im$|gov.gg$|diabetes.org.uk$|thelondonclinic.co.uk$|thewellnessjunction.com$|bramacare.co.uk$|\\w+\\.hscni.net$|\\w+\\.ie$)', 'gm')
const str = `aa3@sss.ie`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}