# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/;(?=[^[]*])/,/gm;t' <<< "[\"Text1;Text2;....;TextN\"];asjkdjksd;ajksdjksad[\"Text1;Text2;....;TextN\"]
.[\"Text1;Text2\"]...long text...[\"Text1;Text2;Text3\"]....long text...[\"Text1;...;TextN\"]...long text...
I ONLY want to change the \";\" in the [\"Text1;...;TextN\"]"