re = /;(?=[^[]*])/m
str = '["Text1;Text2;....;TextN"];asjkdjksd;ajksdjksad["Text1;Text2;....;TextN"]
.["Text1;Text2"]...long text...["Text1;Text2;Text3"]....long text...["Text1;...;TextN"]...long text...
I ONLY want to change the ";" in the ["Text1;...;TextN"]'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result