#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m);(?=[^[]*])"
Local $sString = "["Text1;Text2;....;TextN"];asjkdjksd;ajksdjksad["Text1;Text2;....;TextN"]" & @CRLF & _
"" & @CRLF & _
".["Text1;Text2"]...long text...["Text1;Text2;Text3"]....long text...["Text1;...;TextN"]...long text..." & @CRLF & _
"" & @CRLF & _
"I ONLY want to change the ";" in the ["Text1;...;TextN"]"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)